Skip navigation

Troubleshooting when the Blackberry won’t wirelessly activate 

These are my hints and tips for when your Blackberry device won’t wirelessly activate. I’ve found it best to troubleshoot along the lines of what happens during the activation process:
  

ACTIVATION
 

1. You activate by putting in the password and user email address.
 

2. The Blackberry device then sends an activation request to RIM
 

3. RIM then forwards the activation email to the user’s mailbox
 

What can go wrong here at this stage?
 

 Error Message: “An error occurred. Please contact your System Administrator”.
 

The Blackberry displays the above error message. There are several reasons why this could happen. If this error message is displayed on your Blackberry then check the following:
 

IF you found that as soon as you activate, you get this message and behind this message popup is another message that says: “Activation Failed. An error was encountered when sending the activation transmission”
 

THEN This indicates that the device could not send the activation request email (an ETP.DAT type message).
 

CHECK
 

  • That the user’s activation email address is correct and that you are using the primary Exchange SMTP address.

  

  • Note too that the password will expire if you have had a number of incorrect attempts. The password also automatically expires after 48 hours.

  

  • That the activation email address used is already able to receive mail from external sources.

  

  • That the device is not in a de-active state. If a device hasn’t been used for a while then it can be classed as a de-active device with RIM. Devices in this state won’t activate. A fix that usually works is to turn the Wireless off for over 10 minutes. And then turn on the Wireless.

  

If these steps haven’t worked, it is still likely that the device might still be in a ‘de-active’ state, or that the tariff associated with the SIM card is not Blackberry Enterprise enabled. Call your Telecoms Department or call your Service Provider. Have the SIM card number ready and the device PIN number ready (usually on a label under the battery). They’ll be able to check the state of your device and if it is ‘de-active’, reactivate it.
 

 Error Message: “The server is not responding. Please contact your System Administrator”.
 

 IF you get this error message after a while (typically 30-40 minutes later)
  

THEN This indicates that the device could not send or deliver the activation request email to the mailbox. You can check that this is the case by searching the user’s Inbox only.
  

CHECK
 

 

  • The password set in the Blackberry Manager. When you set this password then this information along with the user’s primary email address is sent to RIM. RIM then expects an activation request from the device. If the password is incorrect then this error can occur. Put in a password again, check the SMTP address set here. Close Blackberry Manager and then reopen, and see that the password is still intact, and try again.

  

  • That there is no rule that would move the ETP.DAT message to a different folder from the user’s Inbox.

  

  • Check that there is no forwarding to another Blackberry user’s mailbox in place on the user’s mailbox. This can result in two identical .DAT messages. BES will be unable to work out who should have the new Blackberry activation.

  

  • Check that RIM sent an ETP.DAT message to the mailbox. Search the user’s Inbox. Check any incoming SMTP logs that are available to you.

  

  • That the device is not in a de-active state. If a device hasn’t been used for a while then it can be classed as a de-active device with RIM. Devices in this state won’t activate. A fix that may work is to turn the Wireless off for over 10 minutes. And then turn on the Wireless. Start the Activation Process again.

 

If these steps haven’t worked, it is still likely that the device might still be in a ‘de-active’ state, or that the tariff associated with the SIM card is not Blackberry Enterprise enabled. Call your Telecoms Department or call your Service Provider. Have the SIM card number ready and the device PIN number ready (usually on a label under the battery). They’ll be able to check the state of your device and if it is ‘de-active’, reactivate it.
  

   

Symptom: The Blackberry is in activation mode and has not ‘progressed’ for some time.
 

 IF the Blackberry device continually displays an Activating or Retrying message
  

THEN This indicates that the device could not send or deliver the activation request email because of an absence of the cellular network, or a problem with an element of the cellular network.
  

CHECK
 

 

  • Coverage by sending a PIN message back to the same device. The PIN number is the same Device PIN that is used to activate the device. If you are unable to send a PIN message this will confirm that there is not sufficient network coverage. Move to an area with improved coverage and try again.
  • The device might not be registered at all on the RIM network. Take the following steps:

  

1. From the Home Screen, choose Options.
 

2. Click Advanced Options – Host Routing Table.
 

3. You may or may not see some table entries. Press the Click Wheel and choose Register Now.
 

   

Error Message: “User <User Name> not started”
 

IF the Blackberry displays the above error message,
  

THEN This indicates that the BES server did not receive the ETP.DAT message, even though this message was delivered to the user’s Outlook Inbox.
  

CHECK
 

 

  • Stop and start the BES server services in the following order:

  

1. Blackberry Router
 

2. Blackberry Dispatcher
 

3. Blackberry Controller
 

  

Be aware that when this is done, mail delivery will be delayed to all devices on the BES Server. Restarting the above services will cause the BES to process the ETP.DAT message, but perhaps several minutes later.
 

  

 I hope that this has helped with any Blackberry activation problems you may have.

Installation Problem with Symantec Enterprise Vault

The Installing and Configuring document that is supplied on the Symantec Enterprise Vault 8.0 DVD rather helpfully leaves you with the following step to follow (on page 58):

3. Give the Vault Service account a “Content manager” role on the Microsoft SQL Server Reporting Services server. Refer to the Microsoft documentation for instructions on how to assign Microsoft SQL Server Reporting Services roles to user accounts.

 

 

Here’s what this means:

In Internet Explorer, type in the following:

http://<server>/reports

..where <server> is the name of your SQL server that hosts the reporting service.

If on doing this, you continually get a blank IE window that mentions a 500 error – well, continually because you continue to repeatedly put in a password to try to gain access – try restarting the SQL Server Reporting Services service.

 

 

 

Click on the Properties tab and then click on ‘New Role Assignment’.

 

In the Group or user name field, type in <domain>\evaccount, where

<domain> is your domain and evaccount is the name of your Vault Service account.

 

Click or select ‘Content Manager’.

Click OK.

 

 

I hope this has been useful to some of you out there.

How to delete the default database in Exchange 2010

You’ll probably want to delete the default database that is created when you build a new Exchange 2010 server. So you’ve moved all the mailboxes that you can see to another database. And then you’ll remove the database.

But if you do try, then you’ll get the following message:

Key Error Messages

The mailbox database ‘Mailbox Database <Numeric>’ cannot be deleted.

This mailbox database contains one or more mailboxes or arbitration mailboxes.

Cause

This is because there are hidden mailboxes.

Solution

Here’s how to find them, move them and then remove the database.

Find them

You’ll need to use the EMS, The Exchange Management Shell, for this.

  1. Use the Get-Mailbox – Database command as I have in the image below:

  2. You’ll see the SystemMailbox, as listed in the image above. You may see more than one mailbox in your listing.
  3. Copy the mailbox name(s) to notepad.

 

Move them

Still within the EMS…

  1. Use the New-MoveRequest command as seen in the image below, pasting back in the mailbox name you copied in the Find them steps above.

  2. If you need to move your arbitration\system mailboxes to a specific database, you could instead use the New-MoveRequest command but add the following switch:

    -TargetDatabase “Database_Name” as shown in the image below.

  3. When you do your move-request, Exchange will queue the move. In the background, Exchange 2010 will perform the move, just as it does for a move performed from EMC.
  4. Repeat step 1 or 2 if you have more mailboxes like this to move.
  5. Use Get-MoveRequest to check that the move has worked:

    You could do this within Move Request in the Exchange Management Console GUI, but you wouldn’t be able to confirm which database the mailbox had moved to.

Remove the database

Remove the database in the usual way in the Exchange Management Console.

I hope this has helped you.